PrinceXML and other dependencies


#1

I have installed PrinceXML via gdebi and declared the variable in wp-config.php.

I have still not installed any of the other dependenices thinking that I should be able to export to PDF.

I am presuming the screenshot is visible so I have two questions :
-does it look like I have installed PrinceXML correctly ?
-do I need to install all the dependencies in order to export to a PDF file ?

Thanks


#2

From my diagnostics report:

Pressbooks Dependencies

Epubcheck: Not Installed
Kindlegen: Not Installed
xmllint: Not Installed
PrinceXML: Installed
Saxon-HE: Not Installed


#3

I have also downloaded a wrapper for php5. The package has two files:
readme.html
prince.php

Do I need to install that somehow ? If yes how ?

Running Ubuntu server 18.04 x64…

Thanks


#4

:point_up: These two must be installed for PDF export. You don’t need this :point_down: