Theme Prerequisites


#1

In the the Pressbooks update (as per snapshot below), the plugin prerequisites are detailed. However, for the themes, there is no indication of requirements for install. I could assume that it would be possible to install Aldine 1.5.0 with PB 5.4.7, which could be a mistake. Perhaps it would be useful to have same information for the Themes as the Plugins?


#2

Hi @sswettenham, currently this isn’t possible. WordPress allows plugin developers to provide “upgrade notes” which are displayed in the plugin update interface but does not provide the same capability for themes. That’s a good idea, though, and would be worth exploring; probably would require getting some functionality added to WordPress core.


#3

If I am on a server frozen at PHP 7.0, would upgrading to the latest themes work? If not, then having a warning could be useful. Thanks,


#4

Well, Pressbooks 5.5 will not work, so whether or not the themes work is less relevant. PHP 7.0 will no longer be receiving security fixes as of December 3, 2018, so you should investigate an upgrade path to PHP 7.1. https://secure.php.net/supported-versions.php


#5

Thanks, but I would have a better chance upgrading themes than PHP. The upgrade path is a cul-de-sac waiting for reconstruction.


#6

So it looks like you are stuck using Pressbooks 5.4 then.